Virtual Cell Quick Start Guide

1. Pre-requisites:

a.
b.

Java (version 1.4.2 or later; 1.5.x recommended)
An Internet connection (broadband, no firewall recommended).

2. Go to http://www.vcell.org/

a.
b.

If you are a new user, first register and create a user name and password.
If you are registered, navigate to the “VCell” page.

3. Click on one of the 2 links to run VCell as an application or as an applet:

a.

b.

C.

The software will download and start automatically (it can take a couple of minutes the first time or
whenever VCell was updated since your last login) — unless you have pop-up blockers enabled and you
are trying to run it as an applet, in which case you must click on the new link “Run the Virtual Cell” after
logging in.

e  Tip: Most operating systems and browsers will work as long as you are running Java 1.4 or later, and there are no
real hardware requirements. However, check the “Technical requirements” link for recommended configurations.

VCell as an application will us Java webstart and will give the option to install a local shortcut.

e  Tip: Whenever you launch VCell from the local shortcut, if you are connected to the Internet, it will automatically
check for and download any updated version.

e Tip: You can run the local VVCell application without an Internet connection and without logging in to the model
database; in this case, however, you will only be able to save your work by using File = Export, and you will not be
able to run simulations and view results until logging in.

VCell as an applet will open in a separate window; do not close the applet browser window, since it will
close VCell without saving.

e  Tip: Configure your Java VM to allocate more memory using startup parameters like “~Xms100M —Xmx200M”

e  Tip: If you become disconnected from the network while working, choose Server - Reconnect once you regain
network connectivity. If you need to exit VCell while disconnected, you can save your work locally by choosing
File > Export and using the (default) VCML format. You can import the resulting XML file once you start a new
VCell session and then save it to the database.

4. Start from an existing model or build a new BioModel from scratch:

a.

To start from an existing VCell model, choose File > Open - BioModel and open a public or shared
BioModel from “Model Neighborhood” (organized in folders by user names). Save your private copy of
it: use File > SaveAs and pick a new name for your copy of the BioModel.
To start from an existing model from other modeling software, first export the model from that software
into SBML or CellML format. In VCell, choose File - Import to import the corresponding file; the
import will create a new BioModel from the imported data.
To start from scratch or edit an existing/imported model, see below.
o  Tip: Refer to the summary description of the primary VCell documents (“files”) at the end of this Quick Start Guide.
e  Tip: Familiarize yourself with VVCell by working with BioModels; you can always use the math from a BioModel
Application as a valid starting point for a MathModel, but you cannot use math from MathModels in BioModels.

Use MathModels only if you are familiar with the \VCell math language and if you encounter a specific limitation of
BioModels that can be overcome by the use of MathModels.

5. To create/edit a BioModel:

a.

b.

An “empty” BioModel is created when VCell starts; at any time you can create a new BioModel by
selecting File > New - BioModel.

The general workflow when using a BioModel is:

create the Physiology

create one or more Applications

create one or more Simulations for each Application

run Simulations

view Results

(optionally) export Results

keep expanding and modifying your BioModel

BioModels are saved in a database. By default, all newly created BioModels are private. Use the
Database Manager (File > Manage database) if you want to make any of your models public (accessible
to all users) or shared (accessible to one or more specific users). Public or shared access is read-only;
only the owner can modify or delete items and other users must save their private copy to make changes.
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e Tip: A BioModel must be internally consistent and saved to the database whenever you want to run Simulations. This
is done automatically, but you will be prompted to take action in one of three cases: (i) the BioModel was never saved
before — you will be prompted to provide a name, (ii) when there are inconsistencies that prevent successful math
generation — you will be presented a (hopefully) understandable error message, or (iii) when saving will overwrite
existing Simulation Results due to upstream changes to the BioModel (and not due just to direct changes to a
Simulation) — you will be given the choice to overwrite, save a new edition of the BioModel, or save the BioModel
under a new name.

e  Tip: When making changes upstream they automatically propagate downstream. For example, creating a new
compartment in the Physiology will propagate to all Applications and spatial Applications will need to have the extra
compartment mapped to the Geometry. For another example, setting a molecular concentration as fixed in an
Application will remove it from the list of variables from all Simulations of that Application. A consequence is that if
you already have simulation results, often some (or all) become invalidated by changes and must be re-run. Itis
important to keep in mind the tree-like hierarchy of the BioModel (Physiology = Applications - Simulations) to
understand VCell behavior during saves and the effects of editing at various levels.

6. Working with the Physiology:

a.

b.
C.

Use the Physiology pane of the main inner window (“Model” window) and begin by creating the
compartments and membranes.
Populate compartments and membranes with molecular species (molecules, complexes, or states thereof).
Create reactions or fluxes in the reaction editor window; this window is invoked separately for each
compartment or membrane.
e Tip: All items in the Physiology window and reaction editor have context menus that pop up on right mouse button
click.
e Tip: You can open more than one BioModel at a time and you can cut and paste molecules or reactions between them.
e Tip: You can search the database for molecules and reactions already defined in all of your models and models of other
users accessible to you (public or shared with you). You can also search public databases — e.g. KEGG for enzyme
reactions that can be automatically inserted into the Physiology

7. Working with Applications:

a.

b.

Create new Applications in the Applications pane of the “Model” window (use the local pull-down menu
Or pop-up context menus).

By default, every new Application is compartmental (i.e., every compartment is treated as homogenous
and without spatial information, and are all mapped to a standard “0-D Geometry”)

e  Tip: Compartmental Applications require proper specifications of the relative volumes of compartments (e.g. nucleus is
20% of the enclosing cell volume) and of the surface-to-volume ratios for each compartment; you should adjust the
default values (0.2 and 1.0, respectively) to whatever is appropriate for your model.

e Tip: Even if your primary goal is to create spatial Applications, compartmental Applications are often an useful starting
point to find or verify parameters for a stable initial state of the system.

To make an Application spatial, click the “View / Change Geometry” button and change the geometry to
any existing saved Geometry.

e  Tip: Spatial Geometries must be created, edited, and saved to the database separately. A Geometry that is being used in
BioModel Application(s) (and/or a MathModel(s)) cannot be deleted or modified; if you edit it, you must save it as a

new edition or under a new name, and if you want to use the new version, you must use the change geometry feature in
the respective Application to point to the new version.

e Tip: In spatial Applications you must always manually map every compartment in your Physiology to a domain
(region) in the Geometry and every region must have at least one compartment mapped to it. A child compartment can
be mapped to the same region as its parent (unresolved, “distributed”).

e  Tip: Always use the surface viewer to inspect 3-D Geometries, especially ones derived from image stacks; there might
be more regions then you think there are, and regions might have illegal common boundaries in places you weren’t
aware of.

Complete the specifications of the Application by working on all four other tabs in the Application
window before moving to the Simulation tab. You can specify boundary conditions, initial
concentrations, enable/disable reactions, set up electrophysiology protocols, etc. Many defaults are OK,
but many may not be.

e Tip: Do not forget diffusion constants for spatial applications. They default to zero for each molecular species, which
may be appropriate for some, but is always illegal when a molecule is involved in a membrane flux.

e Tip: You can specify uneven initial concentrations in spatial Applications by using an expression involving X, y, and z
coordinates.

e Tip: You can specify to use an equilibrium approximation for a reaction by checking the “Fast” checkbox.
You can invoke the Math Viewer window for each Application by pressing the “View Math” button.
Math is regenerated automatically for each Application whenever the BioModel is being saved (manually,
or automatically when running Simulations).

e  Tip: Before using the Simulations tab, if you have made changes to the Application (or to the Physiology), you should
manually regenerate the math of that Application by pressing the “Update Math button”. This way, all (existing or
new) Simulation specifications will be consistent with the current state of your Application.



f.  Use the Simulations tab to create, edit, and run Simulations and view Results.

8. Working with Simulations:
a. Create and manipulate Simulations using the self-explanatory buttons below the list of Simulations.

Tip: Use the Ctrl and Shift keys to select multiple Simulations in the list for copying, deleting, running, and viewing
Results.

b. When creating new Simulations, always check whether the defaults are appropriate for time, solver, and
mesh (if applicable).

Tip: Time step is very important for spatial Simulations — if it is too big, the solver will fail, if it is too small, it may
take too long to run.

Tip: Itis rarely practical or useful to save more then 100 time points for spatial Simulations or more then 1000 for
compartmental ones.

Tip: When spatial simulations run slowly, first experiment with coarse meshes.

Tip: For compartmental applications, try the LSODA solver when stiffness and numerical instability are an issue.

c. Use the “Parameter” tab in the edit simulation window to create Simulations with specific parameter
values being overridden.
d. Simulation Results can be viewed in a separate window invoked by clicking on the “Results” button.

Tip: Results can be viewed while a Simulation is still running; the data displayed will update automatically at the same
time with the Simulation status.

Tip: Line plot windows can display more then one variable at a time — use the Ctrl or Shift keys to select multiple
variables for the Y axis.

Tip: When viewing spatial data, use the point and line tools to mark the display area and fetch spatial or time data for
the selections; time plots and kymographs are often very useful but can take some time to be displayed on very large
datasets.

Tip: You can download data from Simulation Results in a variety of formats from the “Export” tab of Results windows.
Tip: When exporting spatial data into movie formats, you can display more than one variable in the same movie by
selecting the “overlay” checkbox option.

Tip: The NRRD format supports export of full spatial datasets including for 3-D simulations (values for all variables at
all time points and at all points in space).

Tip: Line plot windows have a button to display tabular values that can be copied and pasted directly into other
applications such as a spreadsheet.

e. Parameter Scan allows the user to run complex simulations in which one or more parameters can vary
according to a specified list of possible values or spanning a defined range

Tip: Under “Parameter” tab in the simulation editor, check “Scan” to specify parameters where you would like to do
parameter scan.

Tip: You can provide a list of random values or specify a range by giving min, max and number of values.

Tip: Results of any combination of parameter values can be viewed

9. Export and Import:
a. Use File - Export or File > Import to export and import BioModels to and from local files.

Tip: We support several XML formats. VCML is our native format. SBML and CellML are used for interoperability
with other modeling and simulation software and may not support all features of your BioModel.
Tip: MatLab format supports exporting of math from compartmental Applications.

Tip: Select PDF format to generate a printable description of the BioModel

b. You can export simulation results from the Results window as described above.
c. You can export surface information for Geometries in STL and AVS formats from the Geometry editor.
d. You can export Physiology cartoons in GIF format from local pop-up menus.



Summary of top-level VCell documents

o VCell works with these primary documents: a “BioModel”, a “Geometry”, and a “MathModel”. They are all
stored in an Oracle database and they can be browsed through separate tree hierarchies.

e The database supports multiple editions of documents. When a document is being saved without changing its
name, there are two possibilities: the new document can replace the existing saved version of the document,
or, alternatively, a new edition can be saved under the same name (all editions and can be later opened
separately and/or compared). By default all saved entries are private, but the owner can make them public or
accessible to one or more other VCell users. Public and shared access is read only, users can only change
their own copies of VCell documents.

e A BioModel consists of the “Physiology” (conceptual representation of the model: structures, molecules,
connectivity map, kinetics) and one or more “Applications” (virtual experiments that can be simulated: initial
conditions, actual morphologies, electrical protocols, etc.). An Application can be compartmental or it can
use a Geometry (see below). It has a mathematical representation that is automatically generated and can be
viewed. For each “Application” you can specify one or more “Simulations” (time length, resolution, solvers
to use, parameter overrides, etc.) that will run and produce Results. Results can be viewed in VVCell or
exported to a variety of formats.

o A Geometry is a representation of a spatial structure which a BioModel Application (or a MathModel) can use
for spatially resolved simulations. It can be 1-D, 2-D, or 3-D, and either analytically defined or based on a
digital image.

¢ A MathModel is somewhat equivalent to the math description of a BioModel Application — it is a direct
specification of the equations to be solved, using the VCell modeling language. It can be compartmental or it
can use a spatial Geometry. One or more Simulations must be defined for each MathModel to run and
produce Results.



