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1 Introduction  

The National Resource for Cell Analysis and Modeling has developed the Virtual Cell Modeling and 
Simulation Framework version 4.0. This unique software platform has been designed to model cell 
biological processes. This new technology associates biochemical and electrophysiological data 
describing individual reactions with experimental microscopic image data describing their subcellular 
locations. Cell physiological events can then be simulated within the empirically derived geometries, 
thus facilitating the direct comparison of model predictions with experiment.  

The Virtual Cell consists of a biological and mathematical framework. Scientists can create biological 
models from which the software will generate the mathematical code needed to run simulations. 
Mathematicians may opt to use the math framework, based on the Virtual Cell Math Language, for 
creating their own mathematical descriptions. The simulations are run over the internet on 84 servers 

with 256 GHz total CPU power and 119 GB total RAM. Currently the storage capacity is 11.7 Tb. 

Models can be reused, updated and published so 
they are available to the scientific community. In 
addition, models may also be privately shared 
amongst collaborating groups. The data from 
simulations is stored on the Virtual Cell database 

server and is easily exported in a variety of formats.  

Access to the Virtual Cell modeling software is 
available via the internet using a JAVA based 
interface. Version 4.6 of the Virtual Cell has been 
developed using the latest Java 2 SDK technology. 

1.1  Registration  

There is no charge for academic use of the Virtual Cell, however you are required to register. User 
registration information will aid us in serving the Virtual Cell user community. User registration is 
requested when you download the Virtual Cell client. 

New User Registration  ð vcell.org/webstart/Rel/vcell.jnlp 

1.2 System Requirements  

The following have been tested to be the appropriate system configuration for running the Virtual Cell. 

× Display  

Minimum: 1024x768, 16 bit color, 17'' monitor  

Recommended: 1280x1024 or higher, 32 bit color, 19" monitor  

× Processor  

Minimum: 300 MHz P4 128MB RAM  

Recommended: 550 MHz PIII 256MB RAM or higher  

× Internet Connection  

T1/T3  

Cable Modem/DSL 

1.3 Computer Configuration  

The Virtual Cell is fully supported under Windows 95/98/NT/XP/Vista operating systems. For Mac, G5 
or Intel processor is required for full support.   

http://vcell.org/vcellR4/login/newuser.jsp
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× Windows 95/98/NT/2000/XP/Vista Operating Systems  

The Virtual Cell requires the use of the most current Java 2 Runtime Environment Plug-in  (Download 
Plug-in) installed with the latest versions of most browsers. Your browser should detect whether or not 
you have the plug-in installed on your computer and prompt you appropriately.  

The plug-in is a software product from Sun Microsystems Inc. which enables web authors to direct 
Java Applets to run using Sun's Java Runtime Environment (JRE) instead of the browser's default 
Java virtual machine. This ensures that Java Development Kit (JDK) based applets are executed with 
full support in Internet Explorer and Netscape. Only those pages that specify the plug-in will use the 
plug-in. 

1.4 Using the Virtual Cell Modeling and Simulation Framework with Java Technology  

The Virtual Cell software is currently available to run as the Java applet or the Java Application. In 
either case, you need to have the Java Runtime Environment (JRE) which provides the libraries, Java 
Virtual Machine and other components needed to run applications over the network, and applets in 
browsers. The applications and applets are written in the Java programming language. 

× Java Application  

Java standalone software applications can be run over the network from a link within a HTML page. 
With this technology you will always run the correct version of the Java Runtime Environment (JRE). 
You can get Java Web Start by downloading the JRE, see link above. 

× Running the Java Application (vcell.org/webstart/Rel/vcell.jnlp)  

In order run the Virtual Cell application, you need to have Java installed on your local machine. If this 
is the case, click on the application link and your machine will recognize the application and lead you 
to the Virtual Cell login screen. In addition, it will ensure you have the current JRE required for running 
the application.  

If you do not have Java, your computer will most likely prompt you to save the jnlp file since it does not 
recognize the file type. You need to install Java first, (JRE), follow their downloading instructions. Once 
Java is installed, your computer will recognize the application and bring you to the Virtual Cell login 
screen. 

1.5 User Support  

We have established two emails for contacting the Virtual Cell Developers, one for support and the 
other for comments and suggestions. There are also several tutorials that have been written to help 
the user become familiar with the software while creating simple models. The tutorials lead the user 
step by step through the construction of the BioModel, Geometry, Application, and Simulation. 

× Virtual Cell Support  

Email vcell_support@uchc.edu for assistance with the Virtual Cell. 

× Comments and Suggestions  

Email vcell@uchc.edu for comments or suggestions regarding the Virtual Cell. 

× Virtual Cell Tutorials  

Tutorials have been provided to work in conjunction with the user guide. The tutorials lead the user 
step by step through the construction of the BioModel, Geometry, Application, and Simulation. 

FRAP - http://vcell.org/userdocs/Rel/Tutorial_SimpleFRAP.pdf 

http://java.sun.com/products/plugin/index.html
http://java.sun.com/products/plugin/index.html
http://java.sun.com/j2se/desktopjava/jre/index.jsp
http://java.sun.com/j2se/desktopjava/jre/index.jsp
mailto:vcell_support@uchc.edu
mailto:vcell@uchc.edu
http://www.vcell.org/login/frap.pdf
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FRAP with binding sites - http://vcell.org/userdocs/Rel/Tutorial_FRAPBinding.pdf 

Facilitated Calcium Diffusion in the Intestinal Epithelial Cell -  

http://vcell.org/userdocs/Rel/Tutorial_FacilitatedCalciumDiffusion.pdf 

Hodgkin-Huxley Membrane Potential - http://vcell.org/userdocs/Rel/Tutorial_MembranePotential.pdf 

1.6 Units used in the Virtual Cell  

Unless otherwise noted, all units in the Virtual Cell and in this user guide are as follows: 

 

 

 

 Table of Contents 

Current picoAmperes 

Voltage millivolts 

Time seconds 

Length/Distance micrometers 

Concentration (compartments) micromolar 

Concentration (membranes) molecules per micron squared 

Rate (compartments) micromolar per second 

Rate (membranes) molecules per micron squared per second 

Flux (membranes) micomolar microns per second 

http://www.vcell.org/login/frap_binding.pdf
http://www.vcell.org/login/facil_ca_dif.pdf
http://www.vcell.org/login/membrane_potential.pdf
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2 An overview of the Virtual Cell Documents  

The Virtual Cell software consists of the BioModel , 
Geometry , and Math Model  documents. These are the key 
components within the software and each is saved 
independently of the other although they do reference each 
other.  You can open any document from each of the 
document types. BioModel documents are not specific for 
opening other BioModels. In addition, you can have multiple 
documents open at one time.  

 

 

2.1  BioModel Document  

Once the Virtual Cell is initiated, as a default you are presented with the BioModel document.  The 
BioModel  consists of all the necessary information needed to define the biological model, i.e. species, 
compartments, reactions, fluxes and the Application and Geometry. The Application  establishes the 

relationship between the biological model and the Geometry .  

2.2 Geometry Document  

The Geometry Document consists of the Geometry Editor  and the Surface Viewer for creating, 

editing, and reviewing 1-D, 2-D or 3-D geometries.  

 

2.3 Math Document  

The Math Document consists of the VCML Editor , Equations Viewer , Geometry Viewer  and 
Simulations . The mathematical description is based on the Virtual Cell Math Description Language, 

VCMDL, a declarative mathematics language that has been developed to concisely describe the class 
of mathematical systems that are encountered in the Virtual Cell project.  

 

Table of Contents 
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3 Quick Tour of the Virtual Cell  

The following is a quick tour of the Virtual Cell software from the creation of BioModels to the running 
of Simulations and viewing of results. 

3.1 Creating BioModels  

The Virtual Cell Software is comprised of two components that are required for generating the 
mathematical code needed for running simulations: BioModels and Geometries. The BioModel 
consists of the model description (Physiology), and the Application. The Physiology includes what is 
known about the biological system in terms of cellular structures, species and biochemical reactions. 
The Application allows the user to define the quantitative conditions needed to define, run and 
visualize a Virtual Experiment, i.e. numerical simulation. An Application includes the Structure 
Mapping, Initial Conditions, Reaction Mapping, Electrical Mapping and Simulations. When the 
Application is saved, the Virtual Cell automatically creates the Math Description defining the model. A 
single BioModel may have numerous Applications related to it, in which geometries and/or parameters 
have been changed. In addition, BioModels may have multiple Editions. Editions are useful when 
modifications are made to the same basic model. 

When the software is initiated, a BioModel will 
automatically open with an empty compartment that 
represents a cellular structure. If you choose to open a 
second BioModel, go to File>New>BioModel on the 
Virtual Cell menu bar. 

×  Defining Compartments  

Use the Feature Tool  to add additional cellular 
structures. Select the tool and click once within the 
existing compartment. Membranes are automatically 
created between neighboring compartments.  

× Creating Species  

 Use the Species Tool  to create Molecular Species within the compartments. Select the tool once, 
then click in the compartment where you want the species created.  

× Add Global Parameter  

Global parameters can be numeric constants or expressions. Global parameters can be used in 
reaction rate expressions. Open the ñAdd Global Parametersò dialog to provide the name, expression, 
units and annotations for the new global parameter.   

× Defining Reactions  

 Use the left mouse button to select the compartment or membrane and then use the right mouse 

button within the region to access the Reactions menu. Select Reactions... 

Select either the Reaction Icon  or the Flux Icon  to establish a reaction or a flux condition. Flux 
is available when the cellular structure is a membrane. 

Use the Line Tool  to connect the participating species to the icon. Attach the reactants to the left 
side of the icon and attach the products to the right side of the icon. Select the icon and use the right 
mouse button to access Properties>Reaction Kinetics Editor to define the reaction, or Properties>Flux 
Reaction Editor to define the flux.  
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3.2 Defining Geometries  

You can create a new geometry document from uploaded 
experimental images or from analytically defined conditions. 
When you want to create a Geometry, go to New> 
Geometry>Analytic>1-D, 2-D or 3-D or New> Geometry>From 

Image>Existing Image or Choose Image from File (gif or tif). 

Image based refers to an experimental image that you have 
uploaded to the Virtual Cell image database. See Chapter 6, 
Defining Geometries, for more information. Stored geometries 
are displayed in the Geometry panel of the Database Manager 
(File>Manage Database). Model components referenced by the 

Geometry are also displayed in the directory tree. 

× Geometry Editor  

Geometries are created and modified within the geometry editor. Create new geometries from 
experimental images or define them analytically. Edit the domain for your image based geometry, or 
add an analytic geometry to your existing image. 

× Surface Viewer  

The surface viewer allows you to view the surface of your 3-D data set 
and to rotate it in space. It may also be used for 2-D data sets, for viewing 
the edge of a compartment. 

3.3 Creating Applications  

Applications allow users to define the quantitative conditions needed to define, run 
and visualize a Virtual Experiment, i.e. numerical simulation. The Application is the 
component in which you establish the Structure Mapping between your model and the geometry, and 
define the Initial Conditions and Reaction Mapping. When you create an Application, you create either 
a Deterministic or Stochastic model. In the Application dialog you can also view the software 
generated math code describing the BioModel and the equations used in the simulation. 

The Application directory displays the BioModel 

 that is currently loaded as well as the 

Applications  that are associated with it. In 
addition, you can expand the tree to display the 

Geometry , Math  and Simulation  or 
"run" files associated with the Application. 

× Structure Mapping  

Structure Mapping defines the relationship between 
the physiology (cellular structures) and the 
geometry (subdomains). The cellular structures are 
automatically mapped to a single compartment in 

Compartmental models. View/Change Geometry opens a dialog to select the geometry to be used in a 
spatial model. 

Define the surface area and volume for compartmental models and  unresolved spatial structures. 
Choose between Flux (Neumann) and Value (Dirichlet) boundary conditions for resolved structures. 

Use the Line Tool  for Spatial models, to map the cellular structures from the Physiology to the 
geometric subdomains.  
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× Initial Conditions  

Initial Conditions (concentrations) and Diffusion Constants may be defined in a spatially dependent 
manner. Specify boundary conditions for species with non-zero diffusion (See 7.1 for more detail). 

× Reaction Mapping  

Enable or disable reactions and option for Fast kinetics.  

× Electrical Mapping  

Specify membrane potential options and electrical stimulus. 

× Simulations and Results  

Define simulation run parameters and initiate simulations. The simulator solves the PDEs that 
correspond to diffusive species and the ODEs that correspond to non-diffusive species. 

Compartmental and Spatial simulation results are automatically stored on the database server and 
immediately accessible for review and analysis.  

× View Math  

View the equations and the math description which are generated as a result of mapping the 
physiology model to the compartmental or spatial model.  

× Analysis  

The Analysis tab enabled in Compartmental (nonspatial) models allows users to perform parameter 
estimations to optimize parameters in the model to best fit experimental Data. See Section 7.7 for 

more details.  

3.4 Describing Math Models  

You can generate your own 
mathematical code according to the Virtual Cell Math Description Language, VCMDL, in the Math 
document. VCMDL is a declarative mathematics 
language, which has been developed to concisely 
describe the class of mathematical systems that are 
encountered in the Virtual Cell project. This language 
defines parameters, independent variables, 
differential/algebraic systems defined over a complex 
geometry including discontinuous solutions and 
membrane boundaries and the description of the task 
to perform on such a system.  

 

You can create a math description to generate a 
model, however, you can not then use the software to create a 
BioModel from the math. You may choose to initially create a 
BioModel and use the software to generate a math description. 
You can then import that into the VCML editor and alter the math 
description.  

× VCML Editor  

The VCML editor is the text editor for modifying the math 
description. 

× Equations Viewer  

The viewer displays the math description equations describing the 
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constants, functions, volume domains, and membrane domain. Parameters may be viewed as either a 
name or value. 

× Geometry Viewer  

View the geometry associated with the model. Additional options include Change Geometry and View 
Surface. 

 

 

 

 

 

 

 

 

 

 

 

 

× Simulations  

Define simulation run parameters and initiate simulations based on the mathematical description. 
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4 Managing Your Documents  

The Virtual Cell Modeling and Simulation Framework allows for 
easy maintenance of models. In order to run a simulation, you must 
create a BioModel, which consists of the biological description, and 
the Application, which in turn consists of Structure Mapping, Initial 
Conditions, Reaction Mapping, Electrical Mapping and Simulations. 
Although there are numerous components involved, you only need 
to save the BioModel. Any manipulations you make to the 
components will prompt you to resave the BioModel document.  

A Geometry document is required for spatial models. The Geometry 
is created and saved independent of the BioModel, however it 
references the Geometry file via the Application component of the 
BioModel. Saving options are available within the document in 
which you are working. 

Math descriptions are automatically generated via the software 
when you create an Application. You can take that description and 
use it as a template for a new Math Model or you can create your 
own Math Model from scratch. Whether you create your own math 
model or work from the one generated by the software, the model is 
saved independent of the BioModel and Geometry documents.  

4.1 BioModels, Geometries and Math Models  

× Saving  

Once you have created a document and are ready to save, go to File>Save, Save New Edition, or 
Save As for the available saving options. You need to use the Save New Edition option if you have 
simulation results from a model and you modify your BioModel, Geometry or Math model otherwise 
the simulation results will be lost.  

× Deleting  

Documents can be deleted only from within the Database Manager. You can access the Database 
Manager by going to File>Manage Database. There is a tab for each of three the documents. Make 
sure the document you are interested in deleting is closed prior to deleting it. Select the particular 
document you wish to delete and hold down the right mouse button to access the delete function. 

4.2 Applications and Simulations  

× Deleting Applications  

In order to remove a particular Application of a BioModel, you must be in the Application panel of the 
BioModel. Select the Application you wish to delete, hold down the right mouse button and select the 
delete function or go to Application>Delete. Deleting is only allowed if there are no simulation results 
within the Application. Deleting an Application changes the BioModel, therefore the BioModel needs to 
be re-saved to commit the change.   

4.3 Allowing others to view your models  

Once you have created and saved a complete BioModel, Geometry or Math Model that is suitable for 
public viewing, you are ready to share your model. (If the model does not belong to you, then you can 
not change public viewing settings). 

Open the Database Manager by selecting File> Manage Database and select the BioModel, Math 
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Model or Geometry tab. Click on the document you wish to share 
and either go to Edit>Access Permissions or right-click Permission. 
You now have three options Public, Private or Grant Access to 
Specific Users. 

By default, your model is private which means that only you have 
permission to view the model. If you choose to make your model 
public to anyone using the Virtual Cell, you can select Public. Other 
users can save a copy of your model as their own, and then have 
complete access to their own copy, although no modifications can 
be made to your original copy. 

If you wish to make your model public to specific Virtual Cell users, 
select Grant Access to Specific Users. Type in the login name of 
each user to whom you wish to give access as a public model and 
click Add User. These users will be able to access your model the 
same way that they access any other public model. To all other 
users, this model would be invisible (like a private model). Note that 
when you select Public, the access control list is disabled since all 
users already have public access. 

4.4 Annotations  

Annotations allow you to save text-based notes about a specific 
BioModel, Math Model, or Geometry. In addition, you can save 
annotations about Applications and Simulations. The Annotation notes 
are saved with the model so that you or anyone viewing your public 
model can also view the annotations.  Annotations are stored for the overall model (MIRIAM), Model 
Documents (BioModel, Math Model, Geometries), and  Application and Simulations. 

× Annotations for BioModel Exchange: MIRIAM  

MIRIAM (Minimal Information Requested In the Annotation of biochemical Models) http://

www.ebi.ac.uk/compneur-srv/miriam/  functionality in VCell is part of a collaboration in the general 
modeling community designed to allow biological models to be ñannotatedò with a common structure 
and format describing the components of a mathematical model. VCell users may view/edit MIRIAM 
information in BioModels using the MIRIAM editor accessed from the ñFile -> MIRIAMéò menu 
sequence from any VCell main window.  For more information on editing MIRIAM annotation, see the 
Appendix 

× Annotations in BioModels, Math Models, Geometries  

You must be within the document to create a new annotation. Go to File>Edit Annotation and the 
Annotation dialog will open where you can enter your notes, press ñOKò to accept the entry.  If you 
wish to remove your annotation, repeat the above procedure and remove the text within the dialog and 
press ñOKò, your annotation will be removed from the document.  

× Annotations in Applications and Simulations  

Go to the Application panel of the BioModel document. Select either an Application or Simulation and 
hold down the right mouse button to access the Edit App Annotation option or the Edit Sim Annotation 
option. Enter the text in the dialog as described above. 

4.5 Comparing Models  

It is difficult to compare models by simply visually inspecting the different components.  Instead, the 
best way to compare models is with the Compare Models feature which automatically performs a side-
by-side comparison of all the different components of the model.  

http://www.ebi.ac.uk/compneur-srv/miriam/
http://www.ebi.ac.uk/compneur-srv/miriam/
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To compare models, you can open the tool via the Database Manager 
from one of the documents, File>Manage Database>Compare With>Latest 
Edition, Previous Edition, or Other (a baseline model selection in the 
Database Manager has to be made before choosing an option in the 
Compare With menu); or in the Database Manager, select the baseline 
model and use the right mouse button to Compare With>Previous Edition, 
Another Edition or Another Model. In the dialog that appears, select the 
model you wish to compare against your baseline model and press the 
Open button.   

The models are compared and you are presented with a composite model, 
where only differences are indicated. A X will indicate which part of the 
model is different. The X will originate at the parent level in the tree and 

travel down the tree wherever there is a difference between the two 
models.  At the level where that item is, it will be marked with an ?. Items 
that are only in the modified model are marked with an N for new. Items 
that are only in the baseline model are marked with an R for removed; they 

are considered to be removed from the modified model.  

4.6 Exporting and Importing Models  

VCML is the Virtual Cell Markup Language and the native virtual cell format. The Virtual Cell supports 
interoperability with other standard representations for biological systems modeling. Non-spatial 
BioModels can be easily exported as XML and Matlab files when users want to use their models 
outside of the VCell environment.  

Importing Models  

Within the model document, go to File>Import and select the XML file that you wish to import.   The 
model will be imported into the Virtual Cell. Both levels 1 and 2 of SBML are supported, but it is 
preferable to use level 2, since its more comprehensive than previous SBML versions.   

Unit conversions from SBML  

While importing an SBML model into the Virtual Cell, the units are converted into Virtual Cell default 
units. Note that species in SBML can be represented in terms of substance units or concentration 
units, whereas Virtual Cell represents species only in terms of concentration. An SBML species which 
is defined in substance units is converted to concentration units in the Virtual Cell by dividing the 
quantity in substance units by the size of the compartment in which the species is located. Also, 
reaction rates in SBML are defined in terms of substance/time, which are converted to concentration/
time while importing into the Virtual Cell.  

× Concentration  

The unit conversion factors for species concentration are not explicit to the user. However, conversion 
factors may be found in the óInitial Conditionsô tab of the application. A multiplicative factor may be 
found along with the actual value specified in the SBML model, e.g., 0.01 * 1000000, which means 
that 1000000 is the unit conversion factor for the species. 

× Reaction rate  

Reaction rate unit conversion factors can be seen in the Reaction Kinetics Editor for a reaction. A 
factor ósbmlRateFactorô that represents the unit conversion for the entire reaction rate (from 
substance/time units to concentration/time) will be present in the list of reaction rates and defined 
parameters. For reaction rate expressions that include a species, a corresponding concentration factor 
is also present. For example, if a reaction rate expression contains species ós1ô, ós1ô is multiplied by 
ós1_ConcFactorô to appropriately convert the species units. 
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These conversion factors will also be visible under Model Parameters or the óView Mathô tab of the 
application. In both these places, these concentration and species factors mentioned above appear 
suffixed with the corresponding reaction name. 

SBML models with multiple compartments  

When importing an SBML (level 2) model with more than one compartment, it is important to verify 
that it has a specified relationship between the different compartments. For the Virtual Cell to specify 
the correct cellular structures to each compartment, the relationship between compartments must be 
indicated within the SBML file. This is achieved by specifying in SBML the 'outside' attribute for a 
compartment, and its spatial dimension. In the Virtual Cell, Features have a spatial dimension of 3, 
while membranes have a spatial dimension of 2. 

SBML Import Error/Warning Messages  

See Appendix for current messages and their causes. 

Annotation  

MIRIAM annotations in SBML models are partially supported in the VCell BioModels (See Appendix).  

Exporting Models  

To export a model, open the Bio or Math Model document you wish to export and go to File>Export. 
Determine where you want to save the model on your local drive and select the desired export format 
and press Save.  

If you plan on importing the model back into the Virtual Cell, make sure to export a copy as VCML. 
SBML is an XML that should only be used if you need to import the models into another program that 
requires this formats. 

Exporting to SBML  

SBML export is available only for BioModels. Exporting Math models to SBML will be provided in 
future versions of VCell. SBML only supports non-spatial, deterministic modeling. Also, since there is 
no formal representation for electrophysiological models in SBML, if the BioModel to be exported is 

electrophysiology based, it is simply not exported and an error message is displayed. 

× Multiple non -spatial applications.  

When a VCell BioModel has multiple applications, a list of the non-spatial, deterministic applications is 
presented. Select the application to export to SBML. If the compartment sizes for the selected 
application are not already set, the user is asked to provide the size for any one compartment in the 

BioModel.  

× Mapping Structures  

SBML requires absolute sizes for compartments. If in the selected application, compartment sizes 
have not been set (i.e. in models generated prior to VCell Version 4.4), the user is prompted to provide 

Export Formats Available:   VCell Model Type  

SBML Format Level 1 Version 2 (*.xml) BioModel 

SBML Format Level 2 Versions 1, 2, and 3 (*.xml) BioModel 

VCML Format (*.xml) BioModel, Math Model 

MATLAB v5.0 ODE File (*.m) BioModel, Math Model 

MATLAB v6.0 ODE Function (*.m) BioModel, Math Model 

PDF Files (*.pdf) BioModel, Math Model 
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the size of any one  compartment. Compartment size units 
are um3 for feature and um2 for membrane. All compartment 
sizes will be automatically computed using a constraint 
solver, the user input and relative sizes of the compartments 
(volume fractions and surface to volume ratios).  

The panel to set compartment size is disabled if the sizes of 
all the compartments have been previously set. If a model 
was generated with VCell 4.4 or later, all sizes for non-spatial 
applications are already in the required absolute terms. 

× Unit  Conversions  

While exporting to SBML, Virtual Cell converts species 
concentrations to 'molecules per um3' or 'molecules per um2', 
volume to 'um3', area to 'um2' and kinetic reaction rates to 
substance/time units (molecules/sec). Due to this conversion 
process the user may see additional parameters associated 
with each reaction or species. One such factor is 'KMOLE' or 
sometimes simplified to '0.00166112956810631', or 
'602.0' (1/KMOLE) in the expressions (KMOLE is a 
dimensionless flux conversion factor used internally within the 
Virtual Cell, with a value of 1/602 uM.um3/molecules). See Appendix for more details. 

× Parameter overrides  

If simulations do not have parameter overrides in the selected application, the selected application is 

exported to SBML with its default parameter settings. 

If a selected application has simulations with overridden parameters (parameters changed through the 
simulation task panel), the user is provided a list of these simulation names and the corresponding 
Simulation Summary is displayed. The user can select one of these simulations: highlight name and 
press OK. The selected simulation (with parameter overrides) is exported to SBML.  If the overridden 
parameter is a parameter scan, each scan value is exported into a different SBML file. The names of 
the exported parameter scans will be of the form: exportFileName_Indx.xml. The óexportFileNameô is 
the user-provided name for the exported file. óIndxô is the number of the parameter scan.  

For example, if the simulation has a 
parameter óPô with 5 scan values, 5 
different SBML files are generated. 
each file corresponds to each scan 
value of óPô and óIndxô takes on the 
values 0, 1 ...4;. 

Press Cancel to ignore parameter 
override simulations and have the 
default parameter values of the chosen 

application exported to SBML. 

× Expressions in Initial Conditions  

If the BioModel to be exported contains 
species that have initial conditions 
specified as an expression, such 
species initial conditions are exported to 
SBML as an assignment rule in Level2 
Version1 ONLY IF the species is 
marked as 'Clamped'.  
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4.7 Archive Models  

Designed for use when models are used in publications or need to be saved in a final state. This 
maybe useful when models are a requirement for publication in a journal or associated with textbook 
examples. Models can always be made public through Permissions without archiving. (See Section 
4.3).When model results are reported in publications, it is ideal to make the model public. These can 

then be accessed from the VCell ñPublished Modelsò web page.  

An Archived BioModel or MathModel is protected from deletion or alteration by 
the owner.  Their permissions can be set to either Private or Public. Users may 
wish to Archive the public model and Create a New Edition to continue model 
development. 

The Archive mode is set using the ñDatabase Managerò under the ñFileò main 
menu option.  To set Archive mode, Select a BioModel or MathModel version, 
activate the popup menu and choose ñArchiveò.  A description of the restrictions 
imposed on Archived documents is displayed.  Press OK to set ARCHIVE mode.   

Current Archive restrictions: ARCHIVING cannot be undone without VCELL 
administrative assistance. ARCHIVED versions of 
documents cannot be deleted without VCELL administrative 
assistance. Do you want to ARCHIVE document 
'ModelName' with version date 'Day, Date and Time of 
save'? 
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