
Virtual Cell Quick Start Guide 
 
Go to http://www.vcell.org   Select the Run VCell Run VCell tab 

   
Click on one of the links to download and install the VCell launcher for Windows, MAC or Linux.  The software 
will download, please follow the installer instructions. 

Tip: Whenever you launch VCell from the local shortcut and are connected to the Internet, it will automatically check for and download any 
updated version. 

Tip: You can run the local VCell application without an Internet connection and without logging in to the model database, however, you 
will only be able to save your work using File > Export and your models will not be saved to the database. 

 
The VCell workspace has 4 panes.   

Model Navigation (upper left) to access different parts of 
a Biomodel.   

Database Navigation (lower left) to find public or private 
models or to import models from external data-
bases. 

Main Workspace (upper right) where components of the 
model are described and edited. 

Properties (lower right) that describe the detailed proper-
ties of  selected model components and error 
warnings. 

Tip: There are multiple views for browsing and creating ele-
ments of a model.  For example, species can be specified 
and edited in both Structure and Reaction Diagram views. 
Clicking on Species leads to the list of all species in the model. 

Tip: Select any element in the top right panel and you can view/edit its Object Properties in the bottom right panel. The “Search” field 
provides an easy way to find any specific item in what might be a long list, e.g. 10’s to 100’s of parameters or reactions. 

 
A Searchable Help Manual can be opened from the Help Menu 
 
Working with VCell BioModels:  

 An “empty” BioModel appears when VCell starts; you 
can create a new BioModel by selecting File >New > BioMod-
el. A BioModel consists of the “Physiology” (conceptual repre-
sentation of the model: structures, molecules, connectivity , 
kinetics) and one or more “Applications” (virtual experiments 
that can be simulated: initial conditions, actual morphologies, 
electrical protocols, etc.). An Application can be either continu-
ous, stochastic or rule-based, and either compartmental or spatial 
using a “Geometry”. A “Geometry”, is a representation of a 
spatial structure that a BioModel Application (or a MathModel) 
can use for spatially resolved simulations. It can be 1-D, 2-D, or 3-D, and either analytically defined or based on a 
digital image.  Each application has a mathematical representation that is automatically generated and can be viewed. 
For each “Application” you can specify one or more “Simulations” (time length, resolution, solvers to use, parameter 
overrides, etc.) that will run and produce Results. Results can be viewed in VCell or exported . 

 
Start from an existing VCell BioModel: From the Database navigation pane (bottom left) navigation bar, or click 
on and open a public or shared BioModel from “Shared Models” (organized in folders by user names), 
“Education” (associated with classes and teaching resources) or Tutorials (created to introduce users to VCell). Save 
your private copy: (File > SaveAs) with a new name. 
 
Import an existing model from other software: Models in the BioModels.net repository can be imported using the  
BioModels.net BioModels.net BioModels.net tab in the Database navigation pane; select a model and click the Import Import Import button.  To import other 
models, from VCell choose FileFileFile   > ImportImportImport; VCell supports VCML and SBML files; import will create a new BioModel 
from the imported data. 

 



Create/edit a BioModel: 
♦ create the Physiology 
♦ create one or more Applications 
♦ create one or more Simulations for each Application 
♦ run Simulations 
♦ view Results    ⇒   (optionally) export Results 
♦ keep expanding and modifying your BioModel 

 
BioModels are saved in a database.  

By default, all newly created BioModels are private. A pop-up menu for a selected model in the Database Navigation 
pane (see above) is used to make any of your models public (accessible to all users) or shared (accessible to one or more 
specific users). Public or shared access is read-only; only the owner can modify or delete items and other users must save 
their private copy to make changes. 
Tip: A BioModel must be internally consistent and are automatically saved to the database whenever you want to run Simulations.  You will be 

prompted to take action in one of three cases: (i) the BioModel was never saved – you will be prompted to provide a name, (ii) when there are 
inconsistencies that prevent successful math generation – you will be presented an error message, or (iii) when saving will overwrite existing 
Simulation Results due to upstream changes to the BioModel (and not due just to direct changes to a Simulation) – you will be given the 
choice to overwrite, save a new edition of the BioModel, or save under a new name. 

Tip: When making changes upstream they automatically propagate downstream. For example, creating a new compartment in the Physiology 
will propagate to all Applications and spatial Applications will need to have the extra compartment mapped to the Geometry. For another 
example, setting a molecular concentration as fixed in an Application will remove it from the list of variables from all Simulations of that 
Application.  A consequence is that if you already have simulation results, often some (or all) become invalidated by changes and must be re
-run.  It is important to keep in mind the tree-like hierarchy of the BioModel (Physiology > Applications > Simulations) to understand VCell 
behavior during saves and the effects of editing at various levels. 

 
Working with the Physiology: 

Select Physiology in the Model Navigation pane, and use either Structures (table view) or Reaction Diagram tab in 
the Main Workspace pane to add compartments and membranes. Populate compartments and membranes with molec-
ular species (molecules, complexes, or states thereof). Species can also be added in the Species tab (table view), Reac-
tion Diagram tab or will be automatically created when creating reactions.  Reactions or fluxes are created in the Reac-
tion Diagram or Reactions (table view) tabs.  Within the Reaction Diagram, select different icons for adding species (green 
ball), compartments (circle), reactions (solid line with arrow), reaction modifiers (dashed line) or fluxes (yellow 
pore) . 

Tip: All items in the Physiology window and reaction editor have context menus 
that pop up on right mouse button click. 
Tip: You can open more than one BioModel at a time and you can cut and 
paste molecules or reactions between them. 
Tip: You can search the database for molecules and reactions already defined 
in all of your models and models accessible to you (public or shared with you). 
 

 
 

Working with Applications: 
Right click Applications in the Model Navigation pane, select New Application (Deterministic, Stochastic, etc...). By 
default, every new Deterministic and Stochastic Application is compartmental (i.e., every compartment is treated as 
homogenous and without spatial information, and are all mapped to a standard non-spatial geometry) 

Tip: Compartmental Applications require proper specifications of the surface and volumes of compartments (e.g. a spherical cell with a 10 
micron diameter is 523.33 micrometers cubed). 

Tip: Even if your primary goal is to create spatial Applications, compartmental Applications are often a useful starting point to find or verify 
parameters for a stable initial state of the system. 

To make an Application spatial, select the Geometry, Geometry Definition tabs from the Main Workspace pane, 
click “Add Geometry” and select “New”, or “Open from..” an existing geom-
etry. 

Tip: Spatial Geometries must be created, edited, and saved in the context of a Bio or Math-
Model.  A Geometry that is being used in a BioModel Application (and/or a MathMod-
el) cannot be deleted or modified from the database; if you edit a geometry in use, it 
will be saved as a new edition associated with the model. 

Tip: Structure Mapping in spatial Applications is done manually. Map every compartment in 
the Physiology to a domain (region) in the Geometry; every region must have at least 
one compartment mapped to it.  A child compartment can be mapped to the same 
region as its parent (unresolved, “distributed”). 

Tip: Always use the surface viewer to inspect 3-D Geometries, especially ones derived from 
image stacks; there might be more regions then you think there are, and regions might 
have illegal common boundaries in places you weren’t aware of. 



Select the Specifications tab to complete specifying the Application before moving to the Simulation tab. You can 
specify boundary conditions, initial concentrations and enable/disable reactions. Many defaults are OK, but many 
may not be.  Use the Protocols tab to set up events and electrophysiology protocols, etc.  

Tip: Do not forget diffusion constants for spatial applications.  They default to zero for each molecular species, which may be appropri-
ate in some cases, but is always illegal when a molecule is involved in a membrane flux. 

Tip: You can specify uneven initial concentrations in spatial Applications by using an expression (including Boolean expressions) involving x, 
y, and z coordinates. 

Tip: You can specify use of an equilibrium approximation for a reaction by checking the “Fast” checkbox. 

 
Working with Simulations: 

Create and manipulate Simulations using the Add Copy, Edit , and Delete buttons on the top left.  When 
creating new Simulations, always check that the defaults are appropriate for time, solver, and mesh (in spatial models). 
The top right buttons will select Run get Info access Results or Quick Run (without saving).  

Tip: Use the Ctrl and Shift keys to select multiple Simulations in the list. 
Tip: Timestep is very important for spatial Simulations – if it is too big, the solver will fail, if it is too small, it 
may take too long to run. 
Tip: It is rarely useful to save >100 timepoints for spatial Simulations or >1000 for compartmental ones. 
Tip: When spatial simulations run slowly, first experiment with coarse meshes. 
Tip: For compartmental applications, try the CVODE solver when stiffness and numerical instability are an 
issue. 
Tip: For large compartmental models, try the Quick Run option to get quick results without saving the model 
to the database. Remember to save your model to the database afterwards. 
Use the “Parameters” tab in the edit simulation window to create Simulations in which 
specific parameter values are overridden. 

Tip: Parameter Scan allows you to run simulations in which one or more parameters vary according to a specified list or range of values. 
 
Simulation Results can be viewed in a separate window invoked by clicking on the “Results” icon. 

Tip: Results can be viewed while a Simulation is still running; the data displayed will update automatically at the same time with the Simulation 
status. 

Tip: Line plot windows can display more then one variable at a time – use the Ctrl or Shift 
keys to select multiple variables for the Y axis. 

Tip: When viewing spatial data, use the point and line tools to mark the display area and 
fetch spatial or time data for the selections; time plots and kymographs are often very 
useful but can take some time to be displayed on very large datasets. 

Tip: You can download data from Simulation Results in a variety of formats from the 
“Export” tab of Results windows. 

Tip: When exporting spatial data into movie formats, you can display more than one variable 
in the same movie by selecting the “overlay” checkbox option. 

Tip: The NRRD format supports export of full spatial datasets including for 3-D simulations 
(values for all variables at all time points and at all points in space). 

Tip: Line plot windows have a button to display tabular values that can be copied and pasted 
directly into other applications such as a spreadsheet. 

 
Model Storage: 

The database supports multiple editions of documents. When a document is being saved without changing its name, 
there are two possibilities: the new document can replace the existing saved version of the document, or, alternatively, a 
new edition can be saved under the same name (all editions can be later opened separately and/or compared). By default 
all saved entries are private, but the owner can use ‘Permissions...” functions under the File menu to make them public or 
accessible to other specified VCell users. Public and shared access is read-only, users can only change their own copies 
of VCell documents. 
 

Export and Import: 
Use File > Export or File > Import to export and import BioModels to and from local files.  Tabs or pop-up menus can 
be used to export components of a model.  Simulation results can be exported as Quick Time movies, surface information 
for Geometries can be exported in STL and AVS formats, and the Physiology can be exported as a cartoon in GIF format. 

Tip: MatLab format supports math export from compartmental Applications.  
Tip: Select PDF format to generate a printable description of the BioModel 

 
 

University of Connecticut Health Center, National Resource for Cell Analysis and Modeling, 263 Farmington Avenue, 
Farmington, CT 06030  Tele: 860-679-1452; Fax 860-679-1039; Email: VCell@uchc.edu; URL: www.vcell.org 
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